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1 Introduction — MultiOne workflow 2.0

1.1 System requirements

The minimum system requirements for using MultiOne can be found in the MultiOne
user manual.

1.2 Working with the various MultiOne interfaces

A description of the various MultiOne interfaces can be found in the MultiOne getting
started and the MultiOne user manual.
Note: MultiOne Workflow only supports the USB2DALI and SimpleSet® interfaces.

1.3 Assumed knowledge

To be able to use MultiOne Command Line basic programming skills and a basic
understanding of MS-DOS commands is assumed.
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3 Attention points

3.1 General

Before starting MultiOne Workflow, make sure that the correct interface (USB2DALI,
USB2ZigBee or SimpleSet®) has been connected to your computer.

When upgrading the Windows Operating System, make sure the connection settings
are correct when using MultiOne again.
3.2 DAL

Lighting applications with DALI devices can be seriously affected by the
presence/absence of the DALI short address. Make sure the DALI short address is as
you expect, after finishing working with MultiOne.

3.3 SimpleSet® interface

Although multiple instances of MultiOne Workflow can be started; only the latest
instance that has connected to SimpleSet® can work with the SimpleSet® interface.
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4  Starting with MultiOne Workflow

4.1 Warning

To be sure that the correct feature configuration file is used, it is strongly advised to
use the latest version of MultiOne Engineering to create a feature configuration file.

Otherwise a feature configuration file can be validated by using MultiOne Basic to
write the feature configuration file to the device that needs to be configured.
4.2 Preferences

Within the preferences window you can:

e select the workflow configuration file;
e select the supported devices file;
e enable or disable batch configuring.

r B

Workflow configuration file location:

C:\Users\210169426\Dasktop\Workflow
Supported devices file location:

Enter batch size before configuring

ECEE T

4.2.1 Workflow configuration

To configure Workflow a configuration file is located in: {Your install location}\
WorkflowConfig-TEMPLATE.txt. This file can be used as a template to create your own
configuration file. The created file can be placed in any location on the pc and is used
by selecting it via the Tools->Preferences menu.

To learn how to use this configuration file see chapter: 7 The Workflow
configuration file

4.2.2 Supported devices configuration

To make sure only supported devices can be configured a supported devices file can
be created. The created file can be placed in any location on the pc and is used by
selecting it via the Tools->Preferences menu.
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To learn how to use this supported devices file see chapter: 8 The supported devices
file

4.2.3 Specifying the batch size

In the Tools->Preferences menu, if Enter batch size before configuring is checked,
MultiOne Workflow lets you specify the exact number of devices to configure with a
given feature file. MultiOne Workflow will keep track of progress during configuring.
When all devices have been configured, the current batch will be completed and a
new feature file can be selected.

If Enter batch size before configuring is cleared, an infinite number of devices can
be configured with a given feature file. To select a new feature file click Cancel batch
at any time.

To learn how to enter the batch size see chapter: 5.3 Entering the number of
devices

4.2.4 Activating MultiOne Workflow

Before starting MultiOne Workflow, make sure that a MultiOne interface is connected.
When starting MultiOne the first time, the first window that appears is the MultiOne
Workflow user software key information. Here you can activate your copy of
MultiOne Workflow with your own user software key.

Note: MultiOne Workflow must be connected to the internet upon first usage in order to activate.

I User software key information l&]

Activation status: Mot activated

Key status: Mot activated

Activate...

S

Use the Activate... button to continue activation.
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; )

S ‘i TurboActivate

Activate MultiOne Workflow now

Your activation period has expired and Multione Workflow is no longer working. To use your
software you must activate this copy of Multione Workflow.

2 Activate MultiOne Workflow online now

2 Buy a new product key online

2 Retype your product key

2 Other options...

What is activation?
Read the privacy statement online

Cancel

Select Activate MultiOne Workflow online now and follow the instructions.
The other items on this window are less relevant. For completeness:

Select Buy a new product key online brings you to www.philips.com/MultiOne.

Actually buying keys online is not supported.

Once you have activated MultiOne Workflow with a user software key, you can select
Retype your product key to switch to a different user software key.

The other items shown on the dialog are not supported.

If all goes well the activation is successful and the MultiOne Workflow user software
key information screen should show the correct details and supported features
corresponding to the user software key.
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Activation status: Activated

Key status: OK

User software key details:
Profile:  Workflow
Key:
12MNC: 913700362303

MultiOne is now ready for use.
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5 MultiOne Workflow

5.1 Connection settings

Before you start working with MultiOne Workflow you will need to set the connection
settings. On first start MultiOne Workflow will detect what interfaces are connected to
your PC or laptop.

e When only one interface is connected this one will be automatically chosen.

e When one (or more) USB2DALI and one SimpIeSet® interface is connected the
connection settings window will appear.

e When two USB2DALI interfaces are connected the connection settings window
will appear.

Connecting two SimpleSet® interfaces is currently not supported.

5.1.1 Changing the connection settings
To change the connection settings go to Tools = Connection settings... This option
is only available on the main application window.

Choose the protocol you want to use, DALI for the USB2DALI interface and
SimpleSet® for the SimpleSet® interface.

i Y
1~ Connection seﬂizgl E@g

@ DALI ) SimpleSet

Selected interface [MultiDne DALI interface v]

Selected port [Phil.ipﬁ USB to DALI device v]

=

For the USB2DALI interface you will have the option to select the port that should be
used.
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5.2 Opening a feature file

File Tools Help

MultiOne Workflo: PHILIPS

Using write & verify: no
Identify: every device

Multiple device configuring: no .
Commission all: no Qpen f||e_ o
Check device model: yes

DALI @

To open a feature configuration file, select File > Open... or click Open file... . Select
a file and click Open.
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5.3 Entering the number of devices

File Tocls Help
File: C:\Workspace\featurefile.xml

Device: Xitanium 17W 0.3-1A 24V TD/Is 230V 1.3

Enter number of devices to configure: 1

Cancel batch

If in the preferences the option Enter batch size before configuring was checked,

MultiOne Workflow will display a window in which the number of devices for this
batch can be entered. The minimum number of devices is 1.

If the loaded feature file contains device information it will be shown (see screenshot
above).

Click OK to continue. MultiOne Workflow will now keep track of batch progress
during configuring (the amount of successfully configured devices is shown against
the amount of devices to configure).
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5.4 Connect a device / Waiting for device

5.4.1 Connect a device (USB2DALI interface)

Eile Tools Help

File: C:\workspace\features.xml

Connect a device.

Cancel batch

Use Cancel batch to go to the main application window. Click OK to continue. When

OK is clicked and no device is connected, the following window will appear:

Eile Toecls Help

File: C:\Workspace\features.xml

No connected devices were found

X

Cancel batch

DALI @

Connect a device and click Retry to try again, or click Cancel batch to go to the main
application window.
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5.4.2 Waiting for device.... (SimpIeSet® interface)

Eile Toecls Help

File: C:\workspace\features.xml

Waiting for device...

Cancel batch

Use Cancel batch to go to the main application window. To continue hold the

SimpleSet ®

SimpleSet® interface close to the device.
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5.5 Device connected / Device found

In case of USB2DALI: a device was connected and OK was selected.
In case of SimpleSet®: interface was moved close to the device.

The following windows will appear:

72 MultiOne Workflow

Eile Tools Help

i
File: C:\workspace\features.xml

Identifying...

Cancel batch

After successful identification, the following window will appear:

Do el

Eile Tools Help

File: C:\workspace\features.xml

Writing...

DALT @
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5.5.1 Feature configuration file does not match connected device
After successful identification, the following window will appear in case the feature
configuration file contains a feature which is not supported by the connected device:

File Toecls Help

File: C:\workspace\workflow\features.xml

Loaded feature(s) not supported by device.

X

Cancel batch
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5.6 Configuring done (USB2DALI interface)

After successfully configuring the device, audible feedback can be heard and the

following window appears:

File Tocls Help

File: C:\workspace\features.xml

Done. Connect the next device.

v

Cancel batch

Disconnect the device and connect a new device. Click OK to configure the new

device.
Click Cancel batch to go to the main application window.
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5.7 Remove the device (SimpIeSet® interface)

After successfully configuring the device, audible feedback can be heard and the
following window appears:

Eile Tools Help

File: C:\Workspace\features.xml

Done. Remove the device...

v

Move the SimpleSet® interface away from the device, MultiOne will then show the

Cancel batch

SimpleSet @®

waiting for device view as explained in 5.4.2

Click Cancel batch to go to the main application window.
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5.8 Configuring failed

When configuring failed, an audible feedback can be heard and the following window
appears (This is for both USB2DALI and SimpleSet® interface):

Eile Tools Help

File: C:\workspace\features.xml

Write failed.

ety pId Sk

Cancel batch

SimpleSet @®
To retry the same device, click Retry.

To skip configuring, disconnect the device, connect a new device and click Skip.

Click Cancel batch to go to the main application window.
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5.9 Configuring finished

At any time during configuring, click Cancel batch to go to the main application

window.

If in the preferences the option Enter batch size before configuring was checked
and the specified number of devices have been configured correctly, MultiOne
Workflow will indicate that the batch is finished. Note that devices that could not be
configured correctly (and were skipped by the user) will not be counted for the batch
progress.

File: C:\Workspace\features.xml

Batch finished.

v/

Einish batch

Click Finish batch to go to the main application window.

Select File = Exit or click Close to exit MultiOne Workflow

- MultiCne Workﬂ_

File | Tools Help

Cpen...
Exit

PHILIPS
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6 MultiOne Command Line

MultiOne Command Line only runs from the Windows command line (console, MS-
DOS prompt).

MultiOne Command Line is installed in the same directory as MultiOne Workflow.
6.1 Parameters
MultiOne Command Line is started using the following syntax:

MultiOneWorkflow.exe /f FeatureFile [/w WorkflowFile] [/i Interface] [/v
Verbosity] [/c ContinueOnWarnings]

Or when using a schedule the following syntax:
MultiOneWorkflow.exe /s SchedulerFile /i [/d SupportedDevicesFile]
Note: The scheduler only works with DALL

Parameters between brackets are optional. The parameters have the following

meaning:

Option Parameter Meaning

/f FeatureFile The feature configuration file

/w WorkflowFile The workflow configuration file, see 7 The Workflow
configuration file

/i Interface The MultiOne interface used for communication.
Possible values:
d USB2DALI interface (default)
s SimpleSet® interface

/v Verbosity The verbosity level (the message types that are

shown in the console)
Possible values:
info  Show info, error and fatal messages (default)
error Show error and fatal messages
fatal Show fatal messages only
/c ContinueOnWarnings Whether MultiOne should halt on warnings or ignore
them and continue.
Possible values:

continue Continue on warnings
halt Halt on warnings and produce an
error code

/s SchedulerFile The scheduler file

/d SupportedDevicesFile The supported devices file, see 8 The supported
devices file
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Example usage:

MultiOneWorkflow.exe /f “c:\files\FeatureConfiguration.xml” /w
“c:\files\WorkflowConfiguration.xml” /i d /v fatal /c halt
6.2 Exit codes

In addition to console output, MultiOne Command Line produces an exit code when
terminating. These codes can be used to integrate MultiOne Command Line into a
custom tool chain. The exit codes are listed in the following sections.

6.2.1 General

Exit code Meaning

0 Success

1 User software key not activated

4 Verification failed

5 The interface provided as argument to the command line is
wrong

9 Workflow configuration file not found

10 Workflow configuration file not valid

20 Supported devices file not found

21 Supported devices file not valid

-1 General application failure

6.2.2 Related to writing feature data

Exit code Meaning

101 There are no features to write (there are no features in the
feature file matching the features in the device)

102 Writing failed

6.2.3 Related to resetting the short address of a device

Exit code Meaning

150 Resetting the short address of the device failed

6.2.4 Related to selecting a feature file

Exit code Meaning

200 Feature file not present

201 Invalid feature configuration file

202 Feature configuration file is empty

203 Feature configuration file contains duplicate features

6.2.5 Related to device features and feature file

Exit code Meaning

300 The device does not support all features from the feature
file

301 The device is not of the model specified in the feature file
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6.2.6 Related to traceability

Exit code Meaning

400 Writing traceability information failed

6.2.7 Related to identifying a device

Exit code Meaning

500 No device found

501 Too many devices found

502 Unable to execute discover (There is a problem with the

connection settings / connected devices. Check if the
correct connection settings being used and the MultiOne
interface is connected properly)

503 Multiple devices share the same short address

504 Unsupported device detected

6.2.8 Related to converting a feature file

Exit code Meaning

600 The feature file provided does not contain any features

6.2.9 Related to system preparation

Exit code Meaning

700 No interface connected

6.2.10 Related to converting feature data

Exit code Meaning

800 The feature file provided could not be converted to the
latest version

6.2.11 Related to the scheduler

Exit code Meaning
900 The provided scheduler file is invalid and could not be
loaded.
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7 The Workflow configuration file

The workflow configuration is the same for MultiOne Workflow and MultiOne
Command Line. The configuration file contains the following options (by default all
options will be disabled):

Parameter Meaning

verify When enabled MultiOne Workflow will perform a Write & Verify while
configuring the devices. When disabled only a Write will be performed.
true verify is enabled
false verify is disabled

identifyalways When enabled Workflow will identify every device; otherwise it will

identify only once. Disabling will increase the speed of the configuring
process. (The assumption in the latter case is that MultiOne Workflow is
used to consecutively configure a batch of devices of the same device

type.)
true identifyalways is enabled
false identifyalways is disabled
multidevice When multidevice is enabled MultiOne Workflow will allow multiple

devices of the same device type to be simultaneously configured.
Multidevice cannot be enabled together with the verify option.
When multidevice is enabled identifyalways also has to be enabled.

true multidevice is enabled
false multidevice is disabled
checkdevicemodel When enabled MultiOne Workflow will check if the connected device

matches the device model that is included into the feature configuration
file and raises an error if they do not match. If the feature configuration
file does not contain any information about the device model (files
created with MultiOne 2.6.5 or older) an error will be raised.

true checkdevicemodel is enabled
false checkdevicemodel is disabled
commissionall When commissionall is enabled MultiOne Workflow will commission all

connected devices. Also, when commission all is enabled the short
addresses of the connected devices are not reset anymore

true commission all is enabled

false commission all is disabled

Notice! Before simultaneously configuring devices, the lowest short address needs
to be unique. Therefore, as part of configuring, short addresses might need to be
changed. In case such a change was needed all short addresses will be reset to 255
after configuring. Remember that applications can be affected by a change of the
short address.
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Examples of the workflow configuration file (a template for the configuration file can
also be found in the MultiOne Workflow installation directory):

For consecutive configuring For simultaneous configuring
verify=true verify=false
identifyalways=true identifyalways=true
multidevice=false multidevice=true
commissionall=false commissionall=false

Notice! identifyalways is currently only supported when using DALL. When using
NFC every device will always be identified.

Notice! multidevice is currently only supported when using DALL

Notice! Files in c:\\Program Files or c:\Program Files (x86) can't be edited by Windows
users who don’t have administrator privileges. It is recommended to choose a
different location for the workflow configuration file.
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8 The supported devices file

The supported devices file is a file that describes which devices are supported during
execution. If a connected device is not supported the execution fails. The supported
devices file is the same for MultiOne Workflow and MultiOne Command Line.

Example of the supported devices file (a template for the supported devices file can

also be found in the MultiOne Workflow installation directory):
<?xml version="1.0" encoding="utf-8"?>
<Products xmlns:xsi="http://www.w3.0rg/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.0rg/2001/XMLSchema” FileVersion="1.0">
<Product>
<ProductName>Xitanium 27W 1.0A Prog+ 230V J-sXt</ProductName>
<FactoryFirmwareVersion>VO1EQ1l</FactoryFirmwareVersion>
</Product>
<Product>
<ProductName>HF-Ri TD 3 14/24 TL5 E+</ProductName>
<FactoryFirmwareVersion>1.4</FactoryFirmwareVersion>
</Product>
</Products>

The first line describes the xml version. This never changes.

The second line describes the xml schema used and the version of the supported
devices file. The xml schema specified is the default one and will never change. The
version of the supported devices file can change in the future.

Then, depending on the amount of supported devices for every supported device a
'Product’ element must be specified. Within the ‘Product’ element there are two
subelements called ‘ProductName’ and ‘FactoryFirmwareVersion'. The ‘ProductName’
subelement holds the name of the product where the ‘FactoryFirmwareVersion’ holds
the version of the product.
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9 Changes

The previous configuration file used by MultiOne Workflow located in
c:\temp\workflow.xml has been deprecated and will no longer be supported in a
future version of MultiOne Workflow (& Command Line).

We highly advice you to start using the new configuration file as described in 7 The

Workflow configuration file
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10 Copyright

Copyright © 2014 by Philips Lighting B.V.

All rights reserved. No part of this publication may be reproduced, transmitted,
transcribed, stored in a retrieval system or translated into any language or computer
language, in any form or by any means, electronic, mechanical, magnetic, optical,
chemical, manual or otherwise, without prior written permission from Philips. Brands
and product names are trademarks or registered trademarks of their respective
companies.
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11 Disclaimer

Philips makes no warranty of any kind with regard to this material, including, but not
limited to, the implied warranties of merchantability and fitness for a particular
purpose.

Philips assumes no responsibility for any error that may appear in this document.
Philips makes no commitment to update nor to keep current the information
contained in this document.
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12 Limitations of damages

The vendor will not be liable for any indirect, special, incidental or consequential
damages (including damages for loss of business, loss of profits, or the like), whether
based on breach of contract, tort (including negligence), product liability or
otherwise, even if the vendor or its representatives have been advised of the
possibility of such damages and even if a remedy set forth herein is found to have
failed its essential purpose.
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