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1 Introduction

1.1 System requirements

The minimum system requirements for using MultiOne can be found in the MultiOne
user manual.

1.2 Working with the various MultiOne interfaces

A description of the various MultiOne interfaces can be found in the MultiOne getting
started and the MultiOne user manual.
Note: MultiOne Workflow only supports the USB2DALI and SimpleSet® interfaces.

1.3 Assumed knowledge

To be able to use MultiOne Command Line basic programming skills and a basic
understanding of MS-DOS commands is assumed.
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3 Attention points

3.1 General

Before starting MultiOne Workflow, make sure that the correct interface (USB2DALI,
USB2ZigBee or SimpleSet®) has been connected to your computer.

When upgrading the Windows Operating System, make sure the connection settings
are correct when using MultiOne again.

When starting multiple instances of MultiOne Workflow for parallel configuring, make
sure every instance of MultiOne Workflow uses another interface. The unique id of an
interface is shown in the Connection Settings window where the interface port/reader
is selected. Also, for the currently selected interface the unique id can be found in the
About box and in the tooltip of the connection status indicator in the status bar at
the bottom-right part of MultiOne Workflow.

3.2 DAL

Lighting applications with DALI devices can be seriously affected by the
presence/absence of the DALI short address. Make sure the DALI short address is as
you expect, after finishing working with MultiOne.

3.3 SimpleSet® interface

For SimpleSet® there are three interfaces which can be used for communication (see
the MultiOne user manual): the Philips LCN9600, LCN9610 or LCN9620 MultiOne
interface SimpleSet®.
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4

Starting with MultiOne Workflow

4.1 Warning

To be sure that the correct feature configuration file is used, it is strongly advised to

use the latest version of MultiOne Engineering to create a feature configuration file.

Otherwise a feature configuration file can be validated by using MultiOne Basic to
write the feature configuration file to the device that needs to be configured.

4.2 Preferences

Within the preferences window you can:

select the workflow configuration file
select the supported devices file
enable or disable batch configuring
select the label data location

enable or disable specific label data

il N
e

Workflow configuration file location:

C:\ConfigurationData\WorkflowConfig.txt Browse...

Supported devices file location:

C:\ConfigurationData\SupportedDevices.xml Browse...

[C] Enter batch size before configuring

Label data

Location: | C:\ConfigurationData\GeneratedLabels Browse...

[C] Use custom fields
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4.2.1 Workflow configuration

To configure Workflow a configuration file is located in: {Your install location}\
WorkflowConfig-TEMPLATE.txt. This file can be used as a template to create your own
configuration file. The created file can be placed in any location on the pc and is used
by selecting it via the Tools->Preferences menu.

To learn how to use this configuration file see chapter: 7 The Workflow
configuration file

4.2.2 Supported devices configuration

To make sure only supported devices can be configured a supported devices file can
be created. The created file can be placed in any location on the pc and is used by
selecting it via the Tools->Preferences menu.

To learn how to use this supported devices file see chapter: 8 The supported devices
file

4.2.3 Specifying the batch size

In the Tools->Preferences menu, if Enter batch size before configuring is checked,
MultiOne Workflow lets you specify the exact number of devices to configure with a
given feature file. MultiOne Workflow will keep track of progress during configuring.
When all devices have been configured, the current batch will be completed and a
new feature file can be selected.

If Enter batch size before configuring is cleared, an infinite number of devices can
be configured with a given feature file. To select a new feature file click Cancel batch
at any time.

To learn how to enter the batch size see chapter: 5.4 Entering the number of

devices

4.2.4 Generating and exporting label data

In the Tools->Preferences menu, if the Location in the Label data group is filled in
with a valid folder MultiOne Workflow will generate and export label data (after every
driver configuration) to this folder.

If Use custom fields is enabled, MultiOne Workflow lets you specify 2 extra values
that will be added to the exported label data. This setting can only be enabled when
the Location is provided.

To learn how to enter the custom fields see chapter: 5.43 Entering the custom fields
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The generated label data is stored into a comma separated value file. The filename is
constructed using the device name and the date and time the label data was

generated.

For detailed information about the content of the label data file see chapter: 9 Label

data file contents
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5 MultiOne Workflow

5.1 Connection settings

Before you start working with MultiOne Workflow you will need to set the connection
settings. On first start MultiOne Workflow will detect what interfaces are connected to
your PC or laptop.

e When only one interface is connected this one will be automatically chosen.
e Otherwise the Connection Settings window will appear.

Whenever MultiOne Workflow is started again and a previously selected interface is
not connected anymore the following selection or action will take place:

e When only one interface is connected (independent of the type of interface)
this one will be automatically chosen.

e When two interfaces are connected and one of them is of the same type as the
previously selected interface this interface is automatically selected.

e Otherwise the Connection Settings window will appear.

Connecting multiple similar SimpleSet® interfaces is currently only supported when
using a FEIG interface.

5.1.1 Changing the connection settings
To change the connection settings go to Tools = Connection settings... This option
is only available on the main application window.

Choose the protocol you want to use, DALI for the USB2DALI interface and
SimpleSet® for the SimpleSet® interface.

~
1+ Connection setll_ng' E@Iﬂ

@{DALE © SimpleSet

Selected interface [MultiOne DALI interface v]
Selected port (174717294007 -
o

Then, select the interface. When a DALI interface is selected or when when a FEIG
interface is selected as SimpleSet interface, then also the selected port/reader
(depending on the interface) can be selected.
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For both protocols the unique id of the interface is shown (when available). This, to
be able to identify which interface is used by which MultiOne instance (when
configuring devices in parallel using multiple instances of MultiOne).

When a selected interface contains an outdated firmware version, MultiOne will show
a message that it is unable to connect to the selected interface:

MultiOne can't connect to the selected interface because its firmware version
(02.03.00) is outdated.

5.2 Opening a feature file

MultiOne Workfle PHILIPS

Using write & verify: no
Identify: every device

Multiple device configuring: no .
Commission all: no Qpen file...
Check device model: yes

To open a feature configuration file, select File > Open... or click Open file... . Select

a file and click Open.
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5.3 Entering the custom fields
=

Eile Tocls Help

File: C:\Users\310169426\D...\i TD 2 80 TL5-PL-L E+ 1.121.xml

Device: iTD 2 80 TL5/PL-L E+ 1.121

Custom Field 1

Custom Field 2

Cancel batch

If in the preferences the option Use custom fields as checked, MultiOne Workflow

will display a window in which two custom fields can be filled in. These fields will be
stored together with the generated label data (when filled in).

Click OK to continue.

5.4 Entering the number of devices

e =

File Tools Help

File: C:\Workspace\featurefile.xml
Device: Xitanium 17W 0.3-1A 24V TD/Is 230V 1.3

Enter number of devices to configure: 1

OK

Cancel batch

DALI @
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If in the preferences the option Enter batch size before configuring was checked,
MultiOne Workflow will display a window in which the number of devices for this
batch can be entered. The minimum number of devices is 1.

If the loaded feature file contains device information it will be shown (see screenshot
above).

Click OK to continue. MultiOne Workflow will now keep track of batch progress
during configuring (the amount of successfully configured devices is shown against
the amount of devices to configure).

5.5 Connect a device / Waiting for device

5.5.1 Connect a device (USB2DALI interface)

Eile Tools Help

File: C:\workspace\features.xml

Connect a device.

Cancel batch
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Use Cancel batch to go to the main application window. Click OK to continue. When
OK is clicked and no device is connected, the following window will appear:

7 MultiOne Workflow

Eile Tools Help

File: C:\Workspace\features.xml

No connected devices were found

X =N

DALT @

Cancel batch

Connect a device and click Retry to try again, or click Cancel batch to go to the main

application window.

5.5.2 Waiting for device.... (SimpleSet® interface)

Eile Tools Help

File: C:\workspace\features.xml

Waiting for device...

Cancel batch

SimpleSet ®
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Use Cancel batch to go to the main application window. To continue hold the
SimpleSet® interface close to the device.
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5.6 Device connected / Device found

In case of USB2DALI: a device was connected and OK was selected.
In case of SimpleSet®: interface was moved close to the device.
The following windows will appear:

7 MultiOne Workflow [

Eile Tools Help

i
File: C:\workspace\features.xml

Identifying...

Cancel batch

DALI @®

After successful identification, the following window will appear:

e e =1

Eile Tools Help

File: C:\workspace\features.xml

Writing...
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When the features have been successfully written, the following window will appear if
label printing is enabled:

[~ Philips MultiOne Workfios =

Eile Tocls Help

File: C:\Users\310169426\D...\i TD 2 80 TL5-PL-L E+ 1.121.xml

Device: iTD 2 80 TL5/PL-L E+ 1.121
0/1

Connected: i TD 2 80 TL5/PL-L E+

Generating and exporting label data...

5.6.1 Database file does not exist
After successful identification, the following window will appear in case the database
file is missing:

.
- Philips MultiOne Workflow s R —— - [E=REER
File Tools Help

File: C:\Workspace\features.xml

Device: Xitanium 40W 1.1A 54V DALI SR INT 1.2

Connected:

A database error occurred. Please re-install MultiOne Workflow.

Cancel batch

Click Exit to close the application window and re-install the MultiOne Workflow.
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5.6.2 Feature configuration file does not match connected device
After successful identification, the following window will appear in case the feature
configuration file contains a feature which is not supported by the connected device:

Eile Tocls Help

File: C:\workspace\workflow\features.xml

Loaded feature(s) not supported by device.

poq ke

Cancel batch

5.6.3 OEM Write Protection password is invalid

When using SimpleSet, MultiOne Workflow verifies the password (when a password is
provided in the feature configuration file) with the password that is currently set in
the driver. When a mismatch takes place, the following error will be shown:
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,

Eile Tocls Help

File: C:\Workflow\OWP.xml

Device: LLC1663/01 ActiLume DALI gen2

Connected: LLC1663/01 ActiLume DALI gen2

| The Qem Write Protection password from the feature file is not valid for the driver.

x Retry

Cancel batch
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5.7 Configuring done (USB2DALI interface)

After successfully configuring the device, audible feedback can be heard and the

following window appears:

Eile Tools Help

File: C:\workspace\features.xml

Done. Connect the next device.

v

Cancel batch

Disconnect the device and connect a new device. Click OK to configure the new

device.
Click Cancel batch to go to the main application window.
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5.8 Remove the device (SimpleSet® interface)

After successfully configuring the device, audible feedback can be heard and the
following window appears:

File Tools Help

File: C:\Workspace\features.xml

Done. Remove the device...

v

Move the SimpleSet® interface away from the device, MultiOne will then show the

Cancel batch

SimpleSet ®

waiting for device view as explained in 5.5.2

Click Cancel batch to go to the main application window.
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5.9 Configuring failed

When configuring failed, an audible feedback can be heard and the following window
appears (This is for both USB2DALI and SimpleSet® interface):

Eile Tools Help

File: C:\workspace\features.xml

Write failed.

ety pod Skp_

Cancel batch

SimpleSet ®

To retry the same device, click Retry.
To skip configuring, disconnect the device, connect a new device and click Skip.

Click Cancel batch to go to the main application window.
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5.10 Configuring finished

At any time during configuring, click Cancel batch to go to the main application

window.

If in the preferences the option Enter batch size before configuring was checked
and the specified number of devices have been configured correctly, MultiOne
Workflow will indicate that the batch is finished. Note that devices that could not be
configured correctly (and were skipped by the user) will not be counted for the batch
progress.

| 1~ Philips MultiOne Workflow
Eile Tocls Help

File: C:\Users\310169426\D...\i TD 2 80 TL5-PL-L E+ 1.121.xml
Device: iTD 2 80 TL5/PL-L E+ 1.121

2/2

Connected: i TD 2 80 TL5/PL-L E+

Einish batch

Click Finish batch to go to the main application window.

Batch finished.

Select File = Exit or click Close to exit MultiOne Workflow

4 MultiOne wmn_

e | Tools Help

Open...
Exit

PHILIPS
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6 MultiOne Command Line

MultiOne Command Line only runs from the Windows command line (console, MS-
DOS prompt).

MultiOne Command Line is installed in the same directory as MultiOne Workflow.
6.1 Parameters
MultiOne Command Line is started using the following syntax:

MultiOneWorkflow.exe /f FeatureFile [/w WorkflowFile] [/i Interface] [/v
Verbosity] [/c ContinueOnWarnings] [/l LabelDatalLocation] [/id Uniqueld]

Or when using a schedule the following syntax:

MultiOneWorkflow.exe /s SchedulerFile /i [/d SupportedDevicesFile] [/id
Uniqueld]

Note: The scheduler only works with DALI.
Or when retrieving the list of available DALI or SimpleSet® interfaces:
MultiOneWorkflow.exe /il [Interface]

Parameters between brackets are optional. The parameters have the following

meaning:

Option Parameter Meaning

/f FeatureFile The feature configuration file

/w WorkflowFile The workflow configuration file, see 7 The
Workflow configuration file

/i Interface The MultiOne interface used for communication.
Possible values:
d USB2DALI interface (default)
s SimpleSet® interface

/v Verbosity The verbosity level (the message types that are

shown in the console)
Possible values:
info Show info, error and fatal messages
(default)
error Show error and fatal messages
fatal Show fatal messages only
/c ContinueOnWarnings Whether MultiOne should halt on warnings or
ignore them and continue.
Possible values:
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continue Continue on warnings
halt Halt on warnings and produce an
error code
/s SchedulerFile The scheduler file
/d SupportedDevicesFile The supported devices file, see 8 The supported
devices file
/I LabelDatalocation The folder where to store the generated label data
/il Interface The MultiOne interface type for which to retrieve

the list of available interfaces (with their unique id).
Possible values:

d USB2DALI interface (default)
s SimpleSet® interface
/id Uniqueld The unique id of the interface to use for

communication (retrievable using the /il command
line parameter).

Notice! It is required to use the /i command line
parameter to specify the interface type.

Example usage:

MultiOneWorkflow.exe /f “c:\files\FeatureConfiguration.xml” /w
“c:\files\WorkflowConfiguration.xml” /i d /id 1A2B3C4D5E6 /I “c:\labels” /v
fatal /c halt

6.2 Exit codes

In addition to console output, MultiOne Command Line produces an exit code when
terminating. These codes can be used to integrate MultiOne Command Line into a
custom tool chain. The exit codes are listed in the following sections.

6.2.1 General

Exit code Meaning

0 Success

1 User software key not activated

4 Verification failed

5 The interface provided as argument to the command line
is wrong

9 Workflow configuration file not found

10 Workflow configuration file not valid

20 Supported devices file not found

21 Supported devices file not valid

30 Label data folder could not be created

31 Label data could not be generated

32 Label data could not be exported

-1 General application failure
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6.2.2 Related to writing feature data

Exit code Meaning

101 There are no features to write (there are no features in the
feature file matching the features in the device)

102 Writing failed

6.2.3 Related to resetting the short address of a device

Exit code Meaning
150 Resetting the short address of the device failed

6.2.4 Related to selecting a feature file

Exit code Meaning

200 Feature file not present

201 Invalid feature configuration file

202 Feature configuration file is empty

203 Feature configuration file contains duplicate features

6.2.5 Related to device features and feature file

Exit code Meaning

300 The device does not support all features from the feature
file

301 The device is not of the model specified in the feature file

350 The OEM Write Protection password stored in the feature
file does not correspond with the password in the device.

351 The ALO min value stored in the device is higher than the

ALO value in the feature file.

6.2.6 Related to traceability

Exit code Meaning

400 Writing traceability information failed

6.2.7 Related to identifying a device

Exit code Meaning

500 No device found

501 Too many devices found

502 Unable to execute discover (There is a problem with the

connection settings / connected devices. Check if the
correct connection settings being used and the MultiOne
interface is connected properly)

503 Multiple devices share the same short address

504 Unsupported device detected

6.2.8 Related to converting a feature file

Exit code Meaning
600 The feature file provided does not contain any features

6.2.9 Related to reading feature data

Exit code Meaning
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650 There are no features to read (there are no features in the
feature file matching the features in the device)
651 Reading failed

6.2.10 Related to system preparation

Exit code Meaning

700 No interface connected

6.2.11 Related to converting feature data

Exit code Meaning

800 The feature file provided could not be converted to the
latest version

6.2.12 Related to the scheduler

Exit code Meaning
9200 The provided scheduler file is invalid and could not be
loaded.

6.2.13 Related to the database

Exit code Meaning
1000 The database file is not found. Please re-install MultiOne
Workflow.
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7 The Workflow configuration file

The workflow configuration is the same for MultiOne Workflow and MultiOne
Command Line. The configuration file contains the following options (by default all
options will be disabled):

Parameter Meaning

verify When enabled MultiOne Workflow will perform a Write & Verify while
configuring the devices. When disabled only a Write will be
performed.
true verify is enabled
false verify is disabled

identifyalways When enabled Workflow will identify every device; otherwise it will

identify only once. Disabling will increase the speed of the configuring
process. (The assumption in the latter case is that MultiOne Workflow
is used to consecutively configure a batch of devices of the same
device type.)

true identifyalways is enabled
false identifyalways is disabled
multidevice When multidevice is enabled MultiOne Workflow will allow multiple

devices of the same device type to be simultaneously configured.
Multidevice cannot be enabled together with the verify option.
When multidevice is enabled identifyalways also has to be enabled.

true multidevice is enabled
false multidevice is disabled
checkdevicemodel When enabled MultiOne Workflow will check if the connected device

matches the device model that is included into the feature
configuration file and raises an error if they do not match. If the
feature configuration file does not contain any information about the
device model (files created with MultiOne 2.6.5 or older) an error will

be raised.
true checkdevicemodel is enabled
false checkdevicemodel is disabled
commissionall When commissionall is enabled MultiOne Workflow will commission

all connected devices. Also, when commission all is enabled the short
addresses of the connected devices are not reset anymore

true commission all is enabled

false commission all is disabled

Notice! Before simultaneously configuring devices, the lowest short address needs
to be unique. Therefore, as part of configuring, short addresses might need to be
changed. In case such a change was needed all short addresses will be reset to 255
after configuring. Remember that applications can be affected by a change of the
short address.
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Examples of the workflow configuration file (a template for the configuration file can
also be found in the MultiOne Workflow installation directory):

For consecutive configuring For simultaneous configuring
verify=true verify=false
identifyalways=true identifyalways=true
multidevice=false multidevice=true
commissionall=false commissionall=false

Notice! identifyalways is currently only supported when using DALL When using
NFC every device will always be identified.

Notice! multidevice is currently only supported when using DALL

Notice! Files in c:\\Program Files or c:\Program Files (x86) can’t be edited by Windows
users who don’t have administrator privileges. It is recommended to choose a
different location for the workflow configuration file.
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8 The supported devices file

The supported devices file is a file that describes which devices are supported during
execution. If a connected device is not supported the execution fails. The supported
devices file is the same for MultiOne Workflow and MultiOne Command Line.

Example of the supported devices file (a template for the supported devices file can

also be found in the MultiOne Workflow installation directory):
<?xml version="1.0" encoding="utf-8"?>
<Products xmlns:xsi="http://www.w3.0rg/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.0rg/2001/XMLSchema” FileVersion="1.0">
<Product>
<ProductName>Xitanium 27W 1.0A Prog+ 230V J-sXt</ProductName>
<FactoryFirmwareVersion>VO1EQ1l</FactoryFirmwareVersion>
</Product>
<Product>
<ProductName>HF-Ri TD 3 14/24 TL5 E+</ProductName>
<FactoryFirmwareVersion>1.4</FactoryFirmwareVersion>
</Product>
</Products>

The first line describes the xml version. This never changes.

The second line describes the xml schema used and the version of the supported
devices file. The xml schema specified is the default one and will never change. The
version of the supported devices file can change in the future.

Then, depending on the amount of supported devices for every supported device a
'Product’ element must be specified. Within the ‘Product’ element there are two
subelements called ‘ProductName’ and ‘FactoryFirmwareVersion'. The ‘ProductName’
subelement holds the name of the product where the ‘FactoryFirmwareVersion” holds
the version of the product.
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9 Label data file contents

When label data is generated and stored in a comma separated value file the
contents of the file consists of three lines. The first line contains the column names,
the second line contains the units and the third and line contains the values.

The following table describes which columns are included with which unit and its

value:
\ Column name Unit Value Included \
Date dd- The date the label  Always
MM- data was
yyyy generated

Time Hh:mm The time the label  Always

data was

generated
FeatureConfigurationFilePath n/a The path to the Always

feature

configuration file
FeatureConfigurationFileName n/a The name of the Always

feature

configuration file
Configuration Result n/a Successful or Always

Failed
Custom Field 1 n/a Custom value 1 If configured to

be include
Custom Field 2 n/a Custom value 2 If configured to
be include

Device Model n/a Device model (for  Always

example: Xitanium

Outdoor 150W .35

Prog+ H)

If the driver contains one of the following features:

e AOC

e MTP

e Interface Selection
e Dynadimmer

Their settings are also stored in the label data file.
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10 Changes

The previous configuration file used by MultiOne Workflow located in
c:\temp\workflow.xml has been deprecated and will no longer be supported in a
future version of MultiOne Workflow (& Command Line).

We highly advice you to start using the new configuration file as described in 7 The

Workflow configuration file

© Philips Lighting B.V. 2015 Page 31/ 34



User Manual Philips MultiOne Workflow

11 Copyright

Copyright © 2014 by Philips Lighting B.V.

All rights reserved. No part of this publication may be reproduced, transmitted,
transcribed, stored in a retrieval system or translated into any language or computer
language, in any form or by any means, electronic, mechanical, magnetic, optical,
chemical, manual or otherwise, without prior written permission from Philips. Brands
and product names are trademarks or registered trademarks of their respective
companies.
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12 Disclaimer

Philips makes no warranty of any kind with regard to this material, including, but not
limited to, the implied warranties of merchantability and fitness for a particular
purpose.

Philips assumes no responsibility for any error that may appear in this document.
Philips makes no commitment to update nor to keep current the information
contained in this document.
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13 Limitations of damages

The vendor will not be liable for any indirect, special, incidental or consequential
damages (including damages for loss of business, loss of profits, or the like), whether
based on breach of contract, tort (including negligence), product liability or
otherwise, even if the vendor or its representatives have been advised of the
possibility of such damages and even if a remedy set forth herein is found to have
failed its essential purpose.
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